VoiceJam

VoiceJam | Support

System Requirements

Compatible Devices:

  • iPhone 3g
  • iPhone 3gs
  • iPhone 4
  • iPad
  • iPod Touch **2nd, **3rd, or 4th Generation

**iPod Touch 2nd and 3rd generation devices do not have built in microphones, so you’ll need to attach a microphone enabled headset

Minimum iOS version: 4.0.0

Headphones are highly recommended but not required.

VoiceSupport – Manuals

Voicejam manual

Online support
TC-Helicon is an individual in
TC Electronic | TC-Helicon | Tannoy | Lab.gruppen | Lake | White Acoustics | TC Applied Technologies | Dynaudio Professional